Home    |    Products    |   Support    |    Contact Us
Software Download

v10.0.08.03

Download

(If you do not have Java, this installer includes the latest version of Java Run-Time)

Starting from 2017/05/25, the AccuLive Cloud installer includes the latest version of Java Run-time in the software package. This means that if you have never installed Java, you no longer need to download and install it separately.

Question: What versions of Mac operating systems are supported?

Answer: By default, this release of AccuLive Cloud supports macOS 10.9.5, 10.10.5, 10.11.5 & 10.12.5 (as of 2017/06/18).

Special Notes: When you launch the AccuLive Cloud app from your Mac, system will check for updates from AccuLive server. If there is an update, you MUST install the update immediately. Also, passwords are case-sensitive.

v10.0.08.03

Download

(If you do not have Java, this installer includes the latest version of Java Run-Time)

AccuLive Commander install-based app is compatible with Windows 7, 8 and 10. This app comes with a built-in software updater which checks for update every time you launch the program. If there is a newer version available, you can download and update the app immediately.

Starting from 2013/04/24, the install-based app comes with pre-configured Java Runtime Library. You don't need to worry about what version of Java you jave. it works on both 32-bit and 64-bit Windows computers.

It is recommended, before you proceed with online installation you may need to disable your Internet firewall/anti-virus program. In some cases the default firewall/anti-virus settings are set to reject all automatic or online installations. If this is the case, you may select to SAVE the file on your hard drive, then continue to RUN the installation. This installation program is digitally code signed by the company. It is safe to install the program on your Windows.

Special Notes: When you launch the AccuLive Cloud app from your Windows desktop, system will check for updates from AccuLive server. If there is an update, you MUST install the update immediately. Also, passwords are case-sensitive.

 

Home    |    Products    |  Support    |    Contact Us   |   My Account